After hardware upgrade, server migration, or upgrade across major versions, when you enter the license key or restore settings/backup including license information, you will recieve Reference Key Mismatch error and a notification that your license will be only valid for 7 days if you don't resolve this issue. Here's how.
CAUSE
Server Reference Key is basically a server fingerprint, generated upon installation. For each machine it is unique and it is used as a seed to generate the license block. This is in line with the license agreement which limits you to run one licensed copy of the software on one machine at a time. If the Server Reference Key changes, you can no longer use the license block (key) from the previous installation.
- You can find your Server Reference Key in Merak Administration Console - Help - Licenses dialog.

Its format differs across versions:
Merak 6.0 and above:
113_52866000057742021 (or without the prefix)
Merak 8.2 and above:
82811415-0DC1291E-05492B82-877710E7-MW- If you migrate Merak to a new server, or for any other legitimate reason you need to regenerate the license, follow the instructions below.
NOTE
For server migration, we permit to run both machines in parallel from the same license for a limited period of time, needed to ensure that the migration was successful. After that you are obliged to delete the original installation of the software.
On the new server, you can also run the 30 day evaluation license included within the download throughout the migration process. You need to ensure that license information isn't included within the backup file (System - Tools - System Backup - Options - untick Backup the license). This is not always possible.
Important Notice
The attempts to transfer license to a different machine are limited. Use this procedure carefully, if you exhaust the license regeneration attempts, we will be able to help you only if you justify the extra license releases.
On the other hand, you will still have 7 days to contact us for help.
RESOLUTION
- Follow the link below and choose Request License radio button. http://www.icewarp.com/web2005/purchase/order/index.html
- Enter your last Order ID and Server Reference Key.
Always double check that you are entering the correct values!
- Click Submit.*
- Copy the license block you get to Help - Licenses - Enter License Manually dialog.
- Press Register button.
- You should be notified by a pop-up window saying "Registration Successful".
POSSIBLE ERRORS*
- License purchased through a reseller.
Contact the vendor with your request. Include Order ID and Server Reference Key for fastest processing.
- License purchased before July 2005.
The server might be temporarily inaccessible due to a traffic peak, but usually this means you have entered incorrect values.
You have entered incorrect Order ID or it doesn't exist. It should look like this: IWE20061224-123456-12345678.
- You have exceeded the maximum number of tries.
The license release attempts have been exhausted. Please contact us at
sales.support@icewarp.com, include the Order ID and we will reset the counter if the reason is legitimate (hardware failures, older licenses etc.)
You can also check with us to make sure you can regenerate the license next time you need it.
VERSION 8.9+- Use Help - Licenses - Activate License On-Line button, enter your last Order ID.
If you get an error, use the above described fail-safe method.
VERSIONS PRIOR TO 8.2
Licenses purchased in 2004 and earlier and not updated since that time came with no Order ID, therefore you cannot regenerate the license keys yourself. It is strongly recommended to update your license. If for some reason you need to transfer an old installation of Merak to a different machine, we can do it manually.
- If necessary, download installer of the same version you had from SW archive: http://www.icewarp.com/downloads/archive/winarchive.php
- Install the software on the new server
- Contact us at sales.support@icewarp.com
- Include the Server Reference Key from this installation and exact Product Version (see Help - About..)
- Include company/contact name and e-mail the software was originally registered to so we can identify the order
KB2007022052
updated 16.7.2007 by LukasP